
EDTC 3123 Application of Educational Technologies 
Vocabulary 

 
While we won’t have a “vocabulary test” over the following terms, I will operate under the 
assumption you know these terms and can use them in a basic computer conversation. 
 
Align Left, 
Align Right, 
Center, Justify 

Terms that describe the paragraph format, or position of text, on a page.  Align left means the text 
lines up along a straight line at the edge, or margin, of the page, with the right-side edge uneven. 
This page is left aligned.  Align right aligns the edge of the text along the right margin, and leaves 
the left side uneven. Center positions the text evenly on both sides of an imaginary line down the 
middle of the page.  Justify spreads the text from one margin to the other and makes both edges 
even. Try typing several lines of text and applying the different paragraph formats to the text see 
what happens.  The paragraph format can be changed by highlighting the paragraph you want to 
change, and clicking on one of the formatting buttons in the toolbar. 

Application Another word for program. See below 

Button An on-screen user interface element that simulates the action of a push button. By clicking the 
button, a user initiates a command or action. 

CD-ROM disk A high capacity read-only optical disk that can store up to 680 MB of data. An acronym for 
Compact Disc-Read-Only Memory. 

CD-ROM drive A storage device that uses laser technology to read data from a CD-ROM. 

Central 
processing 
unit (CPU) 

The main processing unit in a computer, consisting of circuitry that executes instructions to 
process data. 

Check box An on-screen box that allows the user to select options clicking the box. 

Click This action is performed when you place your pointer on an icon, and press the button on the left 
side of the mouse, then release the button without moving the pointer. 

Close  By choosing this option from the File menu, it removes the document from the computer screen. If 
you have not saved changes to your document before closing it, the program will ask you if you 
would like to do so. 

Computer 
platform 

A hardware and software configuration shared by a group of computers that use the same 
software and peripheral devices. 

Compatible 
platforms 

Computer brands or models that operate in essentially the same way, use the same software, and 
accept the same peripheral devices. 

Computer A device that accepts input, processes data, stores data, and produces output. 

Computer 
network 

A collection of computers and related devices, connected in a way that allows them to share data, 
hardware, and software. 

Computer 
program 

A set of detailed, step-by-step instructions that tells a computer how to solve a problem or carry 
out a task. 

Copy, Cut, 
Paste 

Text can be moved or copied from one document to another, or from one place in a document to 
another place, by copying or cutting it, and then pasting it. To copy and paste text, put your 
mouse pointer next to the letter on the leftmost side of the text you want to copy. click and drag 
the mouse pointer down to the rightmost point in the text you want to copy. The text area you 
have chosen will then become black, or highlighted.   Choosing Copy from the Edit menu means 
the highlighted text will be copied, and the original text will stay where it was. When you put your 
cursor at a new position, and choose Paste from the Edit menu, the text which you copied 
appears on the screen.  The same actions are performed when text is cut and pasted, but the 
original text is removed from the computer screen. To cut and paste text, highlight the text in the 
same way as when copying and pasting, but choose Cut from the Edit menu instead of Copy. 

 



Cursor A symbol, usually an underline, that marks the user’s place on the screen and shows where 
typing will appear. 

Cursor The blinking vertical line on the computer screen from which letters appear when you type. The 
cursor can be moved to different parts of your document by clicking the mouse pointer on text on 
the screen. 

Data In the context of computing and data management, data refers to the symbols that a computer 
uses to represent facts and ideas. 

Device driver The software that provides the computer with the means to control a peripheral device. 

Dialog box An on-screen window that provides options associated with a command. 

Disk drive A computer storage device that records and retrieves data on disks. Drive types include floppy, 
Zip, and hard disk drives. 

Document A file created by a computer program. A document is usually a file that looks like a page of paper 
when opened, or activated, by a computer program. 

Double-click This action is performed by clicking the mouse button two times in rapid succession. Some mouse 
actions, such as starting a program by clicking on its icon, may require a double-click. 

Downwardly 
compatible 

The ability of an operating system to run application software designed for earlier versions of the 
operating system, but not those designed for later versions. 

Drag This action is performed when you click on an icon or menu, then move the mouse without 
releasing the button. 

Drop-down list A list of options that is displayed when the user clicks an arrow button. 

DVD An optical storage medium similar in appearance and technology to a CD-ROM but with higher 
storage capacity. The acronym stands for “digital video disc” or “digital versatile disc.” 

DVD drive 
(Digital Video 
Disc) 

An optical storage device that reads data from CD-ROM and DVD disks. 

Extension When you save a document, the computer automatically gives a file name an extension, which is 
a period followed by three letters. The program Microsoft Word gives the file name the extension 
.doc. This extension helps the computer identify the program that created the document. 

File A unit of computer information. A file can be a document (see below) or part of a computer 
program (see below). 

Floppy disk A removable magnetic storage medium, typically 3.5” in size with a capacity of 1.44 MB. 

Floppy disk 
drive 

A storage device that writes data on, and reads data from, floppy disks. 

Folder In order to organize documents and other files, “folders” are used in which to place your 
documents, in the same way that paper folders are used to hold paper documents. These folders 
can have names up to eight letters long in Windows 3.1, or several words long in Windows 95. To 
open a folder when saving or opening a document, double-click on the folder’s icon. Several 
folders may be located within one folder. 

Font The letters that make up a computer document can be given a different appearance by choosing 
different fonts, or letters. Fonts come in different shapes and sizes, and can be given different 
styles, such as bold, italics, and underlining. 

Function key The keys numbered Fl through F12, located at the top of the computer keyboard, that activate 
program-specific commands. 

Graphical user 
interface (GUI) 

A type of user interface that features on-screen objects such as menus and icons, manipulated by 
a mouse. Abbreviated GUI (pronounced “gooey”). 



 
Hard disk drive A computer storage device that contains a large-capacity "hard disk" sealed inside the drive case. 

A hard disk is not the same as a 3.5" removable disk that has a rigid plastic case. 

Hardware Electronic and mechanical devices used for input, output, processing, and storing data. 

Icon A graphical representation of an object such as a disk, printer, or program. 

Input As a noun, "input" means the information that is conveyed to a computer.  As a verb, "input" 
means to enter data into a computer. 

Insertion point A flashing vertical bar that appears on the screen, indicating where the user can begin entering 
text. 

Keyboard An arrangement of letter, number, and special function keys that acts as the primary input device 
to a computer. 

Keyboard 
shortcut 

A combination of keys, such as Ctrl+C, that allows the user to activate a program function without 
clicking a series of menu options. 

Macintosh 
computer 
(Mac) 

A microcomputer platform manufactured primarily by Apple Computer Inc. and based on a 
proprietary architecture.  See PC. 

Memory The computer circuitry that holds data waiting to be processed. 

Menu At the top of a the computer screen when a program is open is a list of words (File, Edit, etc.). A 
list of choices, or menu, appears when you click on one of these words with your mouse pointer. 
To choose an action from the menu, drag the pointer down to the choice you want. When you 
reach the choice that you want, release the mouse button, and that choice is activated. 

Monitor A display device that forms an image by converting electrical signals from the computer into 
points of colored light on the screen. 

Mouse  An input device that allows the user to manipulate objects on the screen by moving the mouse on 
the surface of a desk. 

Operating 
System 

The program on a computer that allows you to manage and organize computer documents and to 
run programs. Windows is the name of a popular operating system. There are now several well-
known versions of Windows; the most common are Windows98, Windows2000, and Windows XP. 

Option button An on-screen control that allows a user to select one of two or more options in a dialog box. Also 
referred to as radio buttons. 

Output The results produced by a computer (for example, reports, graphs, and music). 

Password A special set of symbols used to restrict access to a user's computer or network. 

PC 1) A microcomputer that uses the Windows software and contains an Intel-compatible micro-
processor.   2) A personal computer.  See Macintosh computer. 

Peripheral 
devices 

Components and equipment that expand a computer's input, output, and storage capabilities, 
e.g., a printer or scanner. 

Personal 
digital 
assistant 
(PDA) 

A computer that is smaller and more portable than a notebook computer (also called a palm-top 
computer). 

Pointer A symbol on the computer screen, usually shaped like an arrow, whose movement corresponds to 
the movement of the mouse. 

Program Allows you do perform tasks on a computer. To use document files, a program opens them. 
Microsoft Word is the name of a popular program for creating documents. 

Prompt A message displayed on the computer screen that asks for input from the user. 



 
Right-click In Windows, some mouse functions are performed by clicking with the button on the right side of 

the mouse. 

Save After a document is created, a copy of it can be placed on a floppy disk or on the hard drive by 
saving the document. You save a document by choosing Save from the File menu and giving the 
document a file name.  The computer creates an electronic version of the document and places it 
on the drive that you specify (either the hard drive [c:] or a floppy disk [a:]). You can open the 
document later to view, print or make changes to it. 

Save As When you have made some changes to a document and want to save the original document 
without the new changes and the new document with the changes, choose Save As… from the 
File menu when saving your document. Then give the new document a name different from that of 
the original document. 

Software The instructions that set up a computer to do a task, indicate how to interact with a user, and 
specify how to process data. 

Storage media 
Storage 
medium 

The physical material used to computer data, such as a floppy disk, a hard disk, or a CD-ROM. 

Submenu An additional menu of choices that appears when a menu option is selected. 

Toggle key A key such as the Caps Lock key that switches a device back and forth between two modes. 

Toolbar At the top of a program are groups of pictures which look like buttons. The group of buttons 
collectively is called the toolbar. These buttons perform different actions when you click on them. 

User ID A combination of letters and numbers that serves as a user's "call sign" or identification. Also 
referred to as a user name. 

Web browser 
software 

Computer software, such as Netscape Navigator and Microsoft Internet Explorer, that allows 
users to view Web pages and follow links to jump from one document to the next. 

Window A rectangular representation of a work area in a graphical user interface. 

Wizard A sequence of dialog boxes that direct the user through multi-step software tasks, such as 
creating a graph. 

 


